https://www.acmicpc.net/problem/28278
문제
정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 다섯 가지이다.
- 1 X: 정수 X를 스택에 넣는다. (1 ≤ X ≤ 100,000)
- 2: 스택에 정수가 있다면 맨 위의 정수를 빼고 출력한다. 없다면 -1을 대신 출력한다.
- 3: 스택에 들어있는 정수의 개수를 출력한다.
- 4: 스택이 비어있으면 1, 아니면 0을 출력한다.
- 5: 스택에 정수가 있다면 맨 위의 정수를 출력한다. 없다면 -1을 대신 출력한다.
입력
첫째 줄에 명령의 수 N이 주어진다. (1 ≤ N ≤ 1,000,000)
둘째 줄부터 N개 줄에 명령이 하나씩 주어진다.
출력을 요구하는 명령은 하나 이상 주어진다.
출력
출력을 요구하는 명령이 주어질 때마다 명령의 결과를 한 줄에 하나씩 출력한다.
예제 입력 1 복사
9
4
1 3
1 5
3
2
5
2
2
5
예제 출력 1 복사
1
2
5
3
3
-1
-1
문제풀이(1)
1. 1 X: 정수 X를 스택에 넣는다. (1 ≤ X ≤ 100,000)
2. 2: 스택에 정수가 있다면 맨 위의 정수를 빼고 출력한다. 없다면 -1을 대신 출력한다.
3. 3: 스택에 들어있는 정수의 개수를 출력한다.
4. 4: 스택이 비어있으면 1, 아니면 0을 출력한다.
5. 5: 스택에 정수가 있다면 맨 위의 정수를 출력한다. 없다면 -1을 대신 출력한다.
위의 조건에 맞게 스택을 구현하면 된다.
const filePath = process.platform === "linux" ? "/dev/stdin" : "./input.txt";
const [N, ...arr] = require("fs").readFileSync(filePath).toString().trim().split("\n");
class Node {
constructor(value) {
this.value = value;
this.prev = null;
this.next = null;
}
}
class Stack {
constructor(value) {
this.head = null;
this.tail = null;
this.size = 0;
}
push(value) {
const node = new Node(value);
if (!this.head) {
this.head = node;
} else {
node.prev = this.tail;
this.tail.next = node;
}
this.tail = node;
this.size++;
}
pop() {
if (this.size === 0) {
return -1;
}
const value = this.tail.value;
if (this.head === this.tail) {
this.head = null;
this.tail = null;
} else {
this.tail = this.tail.prev;
this.tail.next = null;
}
this.size--;
return value;
}
getSize() {
return this.size;
}
empty() {
return this.size ? 0 : 1;
}
getTop() {
return this.tail ? this.tail.value : -1;
}
}
const stack = new Stack();
let answer = "";
for (let i = 0; i < Number(N); i++) {
const [command, value] = arr[i].split(" ");
switch (command) {
case "1":
stack.push(value);
break;
case "2":
answer += `${stack.pop()}\n`;
break;
case "3":
answer += `${stack.getSize()}\n`;
break;
case "4":
answer += `${stack.empty()}\n`;
break;
case "5":
answer += `${stack.getTop()}\n`;
break;
}
}
console.log(answer.trim());
'Algorithm' 카테고리의 다른 글
[Baekjoon]4134번 다음 소수 - Javascript (1) | 2024.01.01 |
---|---|
[Baekjoon]1969번 DNA - Javascript (1) | 2024.01.01 |
[Baekjoon]2491번 수열 - Javascript (0) | 2023.12.29 |
[Baekjoon]2331번 반복수열 - Javascript (0) | 2023.12.28 |
[Baekjoon]2776번 암기왕 - Javascript (1) | 2023.12.28 |